[Alsaplayer-devel]config/GLIB problems & unavail. hw params

patrick reardon spatrick@flash.net
Sat, 01 Dec 2001 01:36:16 -0600


Alsaplayer version  0.99.52-cvs20011126-jack
Alsa version 0.9.0beta8a
card - Hammerfall
*************************************************************


i tried out cvs (now a few days old) and got the same problem with unavailable
hw params as before.  plus i'm curious about this problem with configure.  i'm
sure it's a problem on my end but i haven't got a clue what to do next.  i tried

hardcoding GLIB_CONFIG = 1.2.10 into configure, but it still notes the following

mismatch:

    "/usr/bin/glib-config --version" returns "1.2.8" but

    "rpm -q glib" returns "glib-1.2.10-ximian.2"

and no GUI is built (possibly? b/c of this).  however there's a file
/usr/lib/glib/include/glibconfig.h which contains the GLIB version definition
and it's 1.2.8.  i didn't find any such file for GLIB 1.2.10.

here's what "./configure --prefix=/usr" reports at the end of its run

*********************
Configuration:

  Install path:                       /usr
  Prefer MAD over mpg123 plugin:      yes
  Build gtk interface:                no
  Build qt interface:                 no
  Build with JACK support:            no
  Build alsa 0.5.x output plugin:     no
  Build alsa LATEST output plugin:    yes
  Build oss output plugin:            yes
  Build esd output plugin:            yes
  Build sparc output plugin:          no
  Build sgi output plugin:            no
  Build nas output plugin:            no
  Build vorbis input plugin:          no
  Build mikmod input plugin:          yes
  Build audiofile input plugin:       no
*****************************


i'm also still getting the "unavailable hw params" error when i try to start
Alsaplayer.  this error occurs both from X and the command line.

*****************************
$ alsaplayer

AlsaPlayer 0.99.52-cvs20011126-jack
(C) 1999-2001 Andy Lo A Foe <andy@alsaplayer.org> and others.
Output plugin: ALSA output v1.9.0beta8
error on set_periods (8)
Unavailable hw params:
ACCESS:  RW_INTERLEAVED
FORMAT:  S16_LE
SUBFORMAT:  STD
SAMPLE_BITS: 16
FRAME_BITS: 32
CHANNELS: 2
RATE: 44100
PERIOD_TIME: (23219 23220)
PERIOD_SIZE: 1024
PERIOD_BYTES: 4096
PERIODS: 2
BUFFER_TIME: (46439 46440)
BUFFER_SIZE: 2048
BUFFER_BYTES: 8192
TICK_TIME: 10000
failed to set fragment size/count. Exiting...
***************************************

advice, anyone?

tia,
patrick





_____________________________________________________________________
VirusChecked by the Incepta Group plc
_____________________________________________________________________