[Alsaplayer-devel]no sound at high speed

brian@corvil.com brian@corvil.com
Mon, 03 Dec 2001 14:13:13 +0000


Hi,

I posted this to alsa-user and it was suggested that here would be more
appropriate.  So, a plea for help:

I've been trying to use alsaplayer but haven't had much success.

First off, I can't get the gui interface to load a file, I click on it in
the gtk file selector but it doesn't try to play it.  However, I can 
specify the filename on the command line, in which case it loads the file
and tries to play it.

This is where I come to the second problem.  I've only tried this with mp3 
files, but in that case it plays the file at high speed and doesn't produce
any sound.  I've also tried using the cdda plugin (my main reason for 
wanting to use alsaplayer) and the same thing seems to happen - high speed
and no sound.

aplay sounds fine and the mp3 file plays fine with mpg123.

Any help would be greatly appreciated.  I compiled with the -DDEBUG and it
is reading the file, in that I see a back-to-back stream of:
  play frame success
  playing frame
  4608 -> 4608

I'm running 2.2.17 with alsa 0.5.9.  I've tried the latest alsaplayer 
sources and 0.99.50 as well.  My soundcard is a Yamaha YMF744B and the 
relevant bit of my modules.conf reads:

  alias char-major-116 snd
  alias char-major-14 soundcore
  alias snd-card-0 snd-card-ymfpci
  alias sound-slot-0 snd-card-0

  alias   sound-service-0-0       snd-mixer-oss
  alias   sound-service-0-1       snd-seq-oss
  alias   sound-service-0-3       snd-pcm-oss
  alias   sound-service-0-8       snd-seq-oss
  alias   sound-service-0-12      snd-pcm-oss

Brian



_____________________________________________________________________
VirusChecked by the Incepta Group plc
_____________________________________________________________________