[Alsaplayer-devel]Won't compile with gcc-3.0

Patrick Shirkey pshirkey@boosthardware.com
Fri, 27 Jul 2001 21:45:33 +0900


Andy Lo A Foe wrote:
>
> > The problems I thought I had created by adding the loop function seem to
> > have dissapeared. I was getting a wierd effect on the position indicator
> > for a little while. After the first loop it would not redraw itself
> > while the bar was moving or else it did it sporadically. That seems to
> > have dissapeared.
> 
> I think this "bug" has been present for a very long time. It looks like
> an update issue in GTK+ itself since I'm not doing anyting special with
> the drawing function, just updating the slider position every n times
> per second.
> 

Ok so it's not me then. It didn't have any affect on the sound so it was
just kind of funky.

> > I have been looking at the code for gnoise and they are using some
> > useful tools with gtk so I'll see if I can start adding some toggle
> > buttons to a preferences box.
> 
> Yes please :)

Just one problem. I can't do any testing until the gcc problem is fixed.
Maybe I should try cvs instead.

Well I would if I could but I can't. I just tried the cvs commands from
the alsaplayer home page. They didn't work. I tried various others using
the commands from the alsa cvs and they didn't work either. Can you tell
me how I could do this please?

> BTW, if anyone's wondering what I'm doing to the code right now:
> - GUI separation and libification.
> 
> I'll repopulate the CVS tree with the current code soon so others can
> join in.
>
 
Great. Some more action at last.



-- 
Patrick Shirkey - Manager Boost Hardware.
Importing Korean Computer Products to New Zealand.
Http://www.boosthardware.com - Cool toys to fufill every geeks fantasy.