[Alsaplayer-devel]mpeg layer 3 plugin too old?

Andy Lo A Foe andy@alsaplayer.org
Sun, 10 Feb 2002 15:57:44 +0100


On Mon, Feb 11, 2002 at 12:44:40AM +1100, David Burrows wrote:

> mpg123 0.59s-mh4 says

Where does one find this version?

> Found new ID3 Header
> Searching for next FF header
> MPEG 1.0 layer III, 160 kbit/s, 44100 Hz joint-stereo

I managed to skip to the next FF header too, but the MAD plugin in
alsaplayer still dies. It might be that I need to upgrade this too.

> file test.mp3 gives
> test.mp3: mp3 file with ID3 2.0 tag

ID3 v2.3 to be exact :)

> My guess is a check to skip over the extra crap (id3 2.0 tag) could solve
> the problem.

Stay tuned...

> Sounds interesting.. :)  I've been thinking of a few other little ideas
> like a pmidi type input plugin, maybe a c64 sid input plugin as well.  I
> realise that midi is not technically a pcm type plugin, but if multiple
> copies of alsaplayer are loaded the ability to manually sync pcm streams
> to midi (close enough to realtime) is too tempting to dismiss. ;)

Sure! It is IMHO very easy to write input plugins for alsaplayer :-)

Andy