[Alsaplayer-devel]mpeg layer 3 plugin too old?

David Burrows snadge@ugh.net.au
Tue, 12 Feb 2002 04:30:58 +1100 (EST)


On Sun, 10 Feb 2002, Andy Lo A Foe wrote:

> On Mon, Feb 11, 2002 at 03:32:42AM +1100, David Burrows wrote:
>
> > It now works for _nearly_ all of them with the odd exception such has
> > http://www.ugh.net.au/~snadge/test2.mp3
>
> Fixed... Please try the CVS...

Excellent, now all of my mp3s work.  One slight caveat is that I'm using a
p166mmx (a classic I know) and libmad has a significantly increased cpu
usage.  I have downloaded madplay seperately and have been trying to
compile it with different optimisations with not much luck.  mpg123 uses
roughly 12% cpu rather than madplay's 30%.  With alsaplayer and libmad
(default optimisations) it can push the usage up to and occasionally over
50% which has less than desirable results when running two copies of
alsaplayer simultaneously.. ;)

Maybe a faster cpu, motherboard, disk and memory will just fall out of the
sky and solve that problem for me.  I doubt it unfortunately. :)

Any ideas?

Regards,
David.