[Alsaplayer-devel]mpeg layer 3 plugin too old?

Andy Lo A Foe andy@alsaplayer.org
Wed, 13 Feb 2002 19:03:41 +0100


On Thu, Feb 14, 2002 at 03:11:58AM +1100, David Burrows wrote:

> I've just spent all day having a play with the mpg123 input plugin.  I
> have managed to hack in ID3v2 support but it doesn't seem to quite work
> properly.  Besides that, the latest version of mpg123 which seems to
> handle all that fine is structured a little bit differently, and I am
> starting to think it is much better.  Is it possible to upgrade the mpg123
> engine to 0.59-s (or r)?

The main reasons I switched to MAD:

1) better sound quality
2) reentrant
3) maintainability

I will of course gladly accept an updated mpg123 based mp3 plugin!

l8r,
Andy