[Alsaplayer-devel]configuring the bootstrap script

Tim Beamish tbeamish@cs.ubc.ca
Fri, 14 Jun 2002 13:01:53 -0700 (PDT)


Okay, I'm still trying to get the latest alsaplayer up and running. I've
done a cvs update on alsaplayer so I have a fresh copy of the code. I
upgraded autoconf to 2.53. I am trying to compile with gcc 2.95.2.

When I run ./bootstrap it fails on this code:
----------------------
	if [ "$AC_VER_MINOR" -lt "50" ]; then
		if [ ! -e configure.in ]; then
			ln -s configure.ac configure.in
		fi
		echo "If you see some warnings about cross-compiling, don't worry; this is normal."
	else
		rm -f configure.in
	fi
----------------------

and removes configure.in. Then when it gets to
run_cmd aclocal $ACLOCAL_INCLUDE
it complains that configure.in doesn't exist.

So I tried forcing configure.in to exist by manually doing:
ln -s configure.ac configure.in
and removing the above if statement. The bootstrap script works and I
see this:

--------------------
running aclocal ...
running autoheader ...
autoheader: warning: `configure.ac' and `configure.in' both present.
 at /usr/local/bin/autoheader line 110
autoheader: warning: proceeding with `configure.ac'.
 at /usr/local/bin/autoheader line 110
autoheader: `config.h.in' is unchanged
running libtoolize --automake ...
running automake --add-missing ...
running autoconf ...
autoconf: warning: both `configure.ac' and `configure.in' are present.
autoconf: warning: proceeding with `configure.ac'.

Now type './configure' to configure AlsaPlayer
--------------------

but then
when I try to do ./configure, I get this:

--------------------
[root@baker alsaplayer]# ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... found
checking whether to enable maintainer-specific portions of Makefiles... no
checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking how to run the C preprocessor... gcc -E
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking whether ln -s works... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for ranlib... ranlib
checking for ld used by GCC... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD-compatible nm... /usr/bin/nm -B
ltconfig: you must specify a host type if you use `--no-verify'
Try `ltconfig --help' for more information.
configure: error: libtool configure failed
----------------------

The configure script fails and nothing will compile.

Any ideas.

Tim