[Alsaplayer-devel]configuring the bootstrap script

Tim Beamish tbeamish@cs.ubc.ca
Mon, 17 Jun 2002 14:26:34 -0700 (PDT)


Okay, the entire compile process works fine. Still, music and no GUI :(

Tim

On Mon, 17 Jun 2002, Andy Lo A Foe wrote:

> On Mon, Jun 17, 2002 at 11:48:33AM -0700, Tim Beamish wrote:
>
> > [root@baker alsaplayer]# autoconf
> > autoconf: Undefined macros:
> > ***BUG in Autoconf--please report*** AC_TRUE
> > ***BUG in Autoconf--please report*** AC_FALSE
> > ***BUG in Autoconf--please report*** AC_TRUE
> > ***BUG in Autoconf--please report*** AC_FALSE
> > ***BUG in Autoconf--please report*** AC_TRUE
> > ***BUG in Autoconf--please report*** AC_FALSE
> > configure.in:261:AC_CHECK_LIB(FLAC, FLAC__file_decoder_new,
> > configure.in:262:     FLAC_LDADD="-lFLAC -lm"; have_flac=yes;
> > AC_DEFINE(HAVE_LIBFLAC, 1, [Define if you have flac library (-lFLAC)]),
> > have_flac=no;
> > FLAC_LDADD=, -lm)
>
> http://www.geocrawler.com/archives/3/1504/2001/8/50/6347936/
> http://www.geocrawler.com/archives/3/1504/2001/8/100/6312073/
>
> (I'm betting Richard was talking about alsaplayer?! :-)
>
> And yes, there is a script that tries to guess which version of autoconf
> to use. If it sees configure.ac it calls autoconf 2.53, if it sees
> configure.in, it calls autoconf 2.13.
>
> I'll go ahead and rename the FLAC stuff to FLC and commit. You should do
> an update and see if that fixes this error. (...just committed)
>
> Also it is probably an error to have duplicate files in both
> /usr/share/acloal and /usr/local/share/aclocal. That would account for
> the screenfulls of duplicate MACRO errors.
>
> Andy
>