[Alsaplayer-devel] rc2

Dominique Michel dominique.michel at citycable.ch
Sun Jul 8 12:15:49 BST 2007


Le Sun, 8 Jul 2007 11:44:50 +0200,
Dominique Michel <dominique.michel at citycable.ch> a écrit :

> Le Sat, 07 Jul 2007 23:24:33 +0100,
> MadeJ <madejos at o2.pl> a écrit :
> 
> > any rc2 plans ?
> > 
> 
> Yes, I will do that today or tomorrow. I committed Hubert Chan workaround for
> the multiple DTITLE lines issue. Only the first line will show up in the
> display and it is better as the last one.
> 
> I am just not sure about gpl v3 upgrade. I took a look into what other
> programs was doing, and it appear at they are just upgrading the licence.
> 
> I think at it is not a good practice if it can make a licence violation. I
> will put an exception at least for the SGI plugin.
> 
> For the other libraries, will a general exception like:
> You are allowed to link, compile and distribute AlsaPlayer against
> GPL-2 softwares.
> be enough?
> 

It look like it is not necessary to do that. According to
http://www.gnu.org/licenses/gpl-faq.html#v2OrLaterPatentLicense

    However, if code is released under GPL “version 2 or later,” that is
compatible with GPLv3 because GPLv3 is one of the options it permits.

So, the only problem with the other libs as sgi, will be if a lib is released
under gpl-2 only. And this is not the case, so the only exception we must have
is for SGI if I understand well.

Dominique



More information about the alsaplayer-devel mailing list