[Xapian-discuss] Fix for 0.8.5 PHP bindings

Olly Betts olly at survex.com
Mon Jan 10 00:28:00 GMT 2005

SWIG 1.3.23 broke wrapping of optional arguments in PHP, and this is the
version that xapian-bindings 0.8.5 was generated with.  I was aware of
the problem, but slipped up making the release - sorry!

If you want to build the PHP bindings, download this:


Then gunzip it, and copy it over the shipped file:


The SWIG problem isn't fixed by 1.3.24, so I'm going to patch the
xapian-bindings build system to explicitly use SWIG 1.3.22 for PHP
bindings until this gets fixed.


More information about the Xapian-discuss mailing list