[Xapian-discuss] Empty results OMEGA with XAPIAN 1.0.1

M.J. van der Veen forward at mvanderveen.nl
Tue Jun 12 14:22:13 BST 2007

On 6/12/07, Olly Betts <olly at survex.com> wrote:
> On Tue, Jun 12, 2007 at 02:57:04PM +0200, M.J. van der Veen wrote:
> > I configured XAPIAN 1.0.1 and OMEGA 1.0.1. on my development machine
> > (first removed the old ones). I recreated my databases (both quartz
> > and flint) and tried to run original queries against the databases
> > created by the new versions.
> Odd, I upgraded xapian.org to 1.0.1 yesterday and that worked.
> > I'm getting empty result sets from OMEGA.
> Does it just return "no matches", or no output at all?

It returns no matches

> > If I use the delve tool I
> > actually see that the records are created fine. No log files are
> > written as far as I know. Are there any methods to debug this?
> You could try the "quest" example, which uses the QueryParser class
> too.

Where do I find this example?

> Also, you could try running Omega from the command line, in case
> there's some output to stderr.

Yes, same result from the commandline

> Also, you can add $querydescription to your OmegaScript template
> which shows how the query gets parsed.

I'll try that. I just built the 0.9.10 version again and it works fine
on the same databases. So the upgrade itself seems to be the problem..

> Cheers,
>     Olly



More information about the Xapian-discuss mailing list